Bigip Edge Client For Mac Sierra

The information below applies to the F5 BIG-IP APM version 14.1.

If you're an F5 Partner, your F5 Support ID gives you access to the resources listed here, but you'll need to create an account on Partner Central to access partner resources. About F5 Corporate Information. Looks like Symantec (SEP 12.1.6MP4) isn't compatible, when installing the beta OS the program is removed and placed in the Incompatible Software folder by the Installer.

Testing Model

F5 Networks supports the functionality of BIG-IP Access Policy Manager on the most-used platforms, and ensures support with the commonly used operating systems (OS) and browsers. Both IPv4 and IPv4+IPv6 deployments are supported, except as noted below.

Supported Access and Endpoint Security Features
FeatureWindowsLinuxMac
ActiveSync and Outlook Anywhere+N/A+
Virtual Keyboard+++
Cache and Session Control+1N/AN/A
AV and FW Check2+++
File Check+++
OS Check+++
Process Check+++
Machine Certificate Check+N/A+
Registry Check+N/AN/A
Protected Workspace+N/AN/A
Windows Info Check+N/AN/A
Machine Info Inspector++3+3
DNS Relay Proxy Service+N/AN/A
Traffic Control Service+N/AN/A
BIG-IP® Edge Client™+++
Inbox F5 VPN Client+4N/AN/A
Network Access++5+
Custom Dialer+6N/AN/A
Reconnect to Domain+N/AN/A
Portal Access+++
Optimized Applications+N/AN/A
Static AppTunnels+N/AN/A
Java AppTunnels+7+7+7,8
Citrix Terminal Services+++
Microsoft RDP Terminal Services+N/AN/A
Microsoft RDP Terminal Services (Java)+7+7+7

1 Cache and Session Control does not remove forms data, passwords and cookies under Firefox and Google Chrome.

2 Visit www.askf5.com for a list of supported antivirus and firewall vendors

3 Machine Info Inspector can only collect MAC addresses on Mac and Linux platforms

4 Inbox F5 VPN client is supported on Windows 8.1

5 For Linux, the Network Access feature does not work with a proxy server

6 IPv6 is not supported

7 Java RDP and Java AppTunnels are not supported on Google Chrome

8 Automatic application launch for Java AppTunnels is not supported on Mac with Safari browser.

OS / Browser and Browser Compatibility

Big Ip Edge Client Mac Sierra

F5 Networks® supports the listed operating systems and browser releases, with the latest service pack or service pack equivalent, for up to 3 years from time of initial release, as long as the listed operating systems and browsers are still supported by the vendor.

If an operating system or browser vendor ends mainstream support before the end of that 3 year period for a release or service pack, F5 Networks® will also end support at the same time. Once an operating system or browser has surpassed the 3 year date from release, F5 Networks® will continue to monitor the user base of this operating system or browser release. When a release reaches a usage level that can no longer justify development, test, and support resources, we will issue an EoL (End of Life) Solution at least three months prior to the planned EoDS (End of Development Support).

Microsoft’s introduction of Servicing Branches in Windows 10 has changed the F5 Networks® support policy for Windows 10 as follows:
F5 Networks® will support Microsoft Windows 10 Current Branch (CB) releases, Current Branch For Business (CBB) releases, and Long Term Servicing Branch (LTSB) releases, up to two years from the initial release date, as long as such a release is within the “mainstream support” period.
Once a release has passed two years from the release date, F5 Networks® will monitor the user base of this release. When a release reaches a usage level that can no longer justify development, test, and support resources, we will issue an EoL (End of Life) Solution at least three months prior to the planned EoDS (End of Development Support).

See https://support.microsoft.com/en-us/help/13853/windows-lifecycle-fact-sheet for more details. For specific information about which builds Microsoft supports as part of its servicing branches, see https://technet.microsoft.com/en-us/itpro/windows/manage/waas-overview#servicing-branches.

Important: This policy only applies to the BIG-IP end-user interfaces, and not the administrative web console for BIG-IP, or any other F5 product.

Microsoft® Windows OS

F5 Networks supports 32-bit and 64-bit versions Windows® Vista SP2 running IE9, Firefox 34 or Chrome 40* and Windows® 7 SP1 and Windows 8.1 Update and Windows 10** running IE11, Firefox 34 or Chrome 40*.

  • Only 32-bit browsers are supported.
  • **Please install Hotfix-BIGIP-12.0.0.1.0.625-HF1.iso for Windows 10 support.
  • Microsoft Edge browser is not supported.
  • Edge Client is not supported when Windows 10 Device Guard is enabled.

Linux Operating Systems

F5 Networks supports all 32-bit x86 and 64-bit x86_64 Linux operating systems (OS) with enabled Kernel support for PPP interfaces and libc version 2 or later, running Firefox 34 or Chrome 40*.

OS X and macOS

F5 Networks supports macOS Sierra (10.12), Apple® OS X® 10.11, Apple® OS X® 10.10, and Apple® OS X® 10.9 devices running Firefox 34, Safari 6.x, Safari 7.x, Safari 8.x, Safari 9.x, or Chrome 40*. Additional support details for this platform include the following:

  • To use endpoint checks with macOS Sierra (10.12), EPSEC build 450.0 must be installed on the Access Policy Manager.
  • Only manual plugins installation is supported
  • On Chrome versions 34 and above, there is limited feature support due to browser restrictions as mentioned in SOL15326. Only the following clientless features are supported: Portal Access, Citrix and VMware Webtop based launch support. The following clientless features are not supported: End Point Security checks, Protected Workspace, Network Access, MS RDP, Static AppTunnels, Dynamic Optimized AppTunnels, Java RDP, and Java AppTunnels.

Android

F5 Networks supports Android™ versions 4 to 5.

For Network Access functionality, please install F5 BIG-IP Edge Client from Google Play. Customers running Android 4.0 or later should install Android EDGE Client for Android 4.x. Also, for secure mobile access to enterprise web applications F5 provides BIG-IP Edge Portal, which can also be downloaded from Google Play.

iOS

F5 Networks supports Apple® iOS® versions 9 and 10. For Network Access functionality please install F5 BIG-IP Edge Client from iTunes. Also, for secure mobile access to enterprise web applications F5 provides BIG-IP Edge Portal, which can also be downloaded from iTunes.

  • Apple® iOS® 9 and 10 are supported

Windows RT and Phone

Windows RT and Windows Phone 8 are supported with clientless features (Portal Access, Java RDP, Java AppTunnels, Citrix and VMware Webtop-based launch). Internet Explorer supports Portal Access and Webtop features. Please note the following exceptions:

  • Applications tunnels and MSRDP Terminal Services are not supported on these platforms. Windows RT supports Network Access through Inbox F5 VPN Client. Windows 8.1 supports Network Access using BIG-IP Edge Client Windows 8.1, avaiable from the Windows Phone Store.

Chrome OS

Clientless features (Portal Access, Citrix and VMware Webtop based launch) are supported on Chrome OS.

For Network Access functionality please install F5 Access for Chrome OS from Chrome Web Store.

Java Compatibility Matrix

F5 Networks supports Java SE 6, Java SE 7, and Java SE 8. Java-related features cannot be utilized using Google Chrome on OS X and Linux because Google Chrome does not support Java plugin on OS X and Linux.

Portal Access Compatibility

The Portal Access feature supports the following applications:

  • Microsoft® Outlook® Web Access (OWA) 2007 and Microsoft® Outlook® Web App (OWA) 2010, 2013 with Microsoft® Lync™ Server 2010, 2013 Integration
  • Microsoft® SharePoint® 2007, 2010 and Services 3.0, 2013
  • MS Office Applications integration with SharePoint and Internet Explorer is not supported
  • Microsoft® Communicator® 2007 R2
  • IBM Lotus® Domino® Web Access 8.0 and iNotes® 9.0 with Sametime®
  • Oracle® Portal 3.0 (10g Release 2, Version 10.1.2)
  • Oracle® PeopleSoft Portal (Version 9)
  • SAP® ERP Central Component (ECC) 2005 and SAP NetWeaver® 7.0 (2004s) SP12
  • F5 Enterprise Manager™ 3.1.1

Outlook Anywhere Compatibility

Outlook Anywhere supports the following versions of client applications:

  • MS Office 2007 for Windows
  • MS Office 2010 for Windows
  • MS Office 2011 for Mac
  • MS Office 2013 for Windows

F5 Networks Big Ip Edge Client

Citrix Compatibility

F5 BIG-IP APM Secure Proxy supports the following server products:

  • XenApp 5, 6, 6.5, 7.5, 7.6, 7.7, 7.8, 7.9, 7.11
  • XenDesktop 4, 5.6, 7, 7.1, 7.5, 7.6, 7.7, 7.8, 7.9, 7.11
  • Web Interface 4.5, 5.2, 5.4
  • Storefront 1.2, 2.0, 2.1, 2.5, 2.6, 3.0, 3.6, 3.7
  • Citrix Receiver for HTML5 0.9 (Storefront 1.2)
  • Citrix Receiver for HTML5 1.0 (Storefront 2.0)
  • Citrix Receiver for HTML5 1.1 (Storefront 2.1)
  • Citrix Receiver for HTML5 1.3, 1.4, 1.5, 1.6 (Storefront 2.5 and 2.6)
  • Citrix Receiver for HTML5 1.7 (Storefront 3.0)
  • Citrix Receiver for HTML5 2.0 (Storefront 3.5 and 3.6)

Following clients were tested:

Edge
  • Citrix Receiver for Windows 4.0, 4.1, 4.2, 4.3, 4.4
  • Receiver for Windows RT v1.3 and 1.4
  • Citrix Receiver for Java 10, 10.1
  • Citrix Receiver for Linux 12.0, 12.1
  • Citrix Receiver for Mac 11.7, 11.8, 11.9, 12.0
  • Citrix Receiver for iOS 5.8, 5.9
  • Citrix Receiver for Android 3.4, 3.5. 3.6, 3.7, 3,8, 3.9*
  • Citrix Online plug-in 12.3
  • Dell Wyse Xenith Zero client: Xenith C00X with 1.7_122 firmware version
  • Dell Wyse Xenith Zero client: Xenith Pro 2 D00X with 2.0_104 firmware version

*Please use the solution https://support.f5.com/kb/en-us/solutions/public/k/01/sol01446161.html to enable support for Citrix Receiver for Android 3.9

VMware View Compatibility Matrix

F5 BIG-IP APM Secure PCoIP Proxy supports the following server products:

  • VMware Horizon View 5.2
  • VMware Horizon View 5.3
  • VMware Horizon View 6.0
  • VMware Horizon View 6.1
  • VMware Horizon View 6.1.1
  • VMware Horizon View 6.2
  • VMware Horizon View 6.2.2
  • VMware Horizon View 7.0*
  • VMware Horizon View 7.0.2*
  • VMware Horizon View 7.0.3*

*Please use the solution: https://support.f5.com/kb/en-us/solutions/public/k/84/sol84958121.html to enable APM support for VMware Horizon View 7.0

Bigip Edge Client For Mac Sierra

The following clients were tested:

  • VMware Horizon View Client for Windows 2.3, 3.0, 3.2, 3.3, 3.4, 4.0.1, 4.1, 4.2, 4.3
  • VMware Horizon View Client for Windows Store 3.2, 3.4
  • VMware Horizon View Client for Mac 2.3, 3.0, 3.1, 3.2, 3.4, 4.0.1, 4.1, 4.2, 4.3
  • VMware Horizon View Client for iOS 2.3, 3.0, 3.1, 3.2, 3.4, 4.0.1, 4.1, 4.2, 4.3
  • VMware Horizon View Client for Android 2.3, 3.0, 3.1, 3.2, 3.4, 4.0.1, 4.1, 4.2, 4.3
  • VMware Horizon View Client for Linux 2.2, 3.2, 3.4, 4.0.1, 4.1, 4.2, 4.3
  • Dell Wyse P25 Zero Client starting from firmware v4.1.0
  • VMware Horizon View HTML5 Client*

* BIG-IP APM currently does not support launching HTML5-enabled RDS applications

Torrent Client For Mac

Remote Desktop Gateway Compatibility Matrix

F5 BIG-IP APM Secure Remote Desktop Gateway supports the following server products:

  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2008 R2 SP1*
  • Microsoft Windows 7 SP1*
  • Microsoft Windows 8.1

*Please install Microsoft Windows KB2592687

The following clients were tested:

  • Microsoft Remote Desktop for Mac 8.0.7
  • Microsoft Remote Desktop for Android 8.0.6, 8.0.11, 8.1.3
  • Microsoft Remote Desktop for iOS v 8.0.7, 8.1.4
  • Microsoft Remote Desktop for Windows 6.3
  • Microsoft Remote Desktop for Windows 6.2

Big Edge Ip Client Installer

The Palo Alto GlobalProtect VPN client is the software used to connect to Dartmouth's VPN.

It should be pre-installed on any machine configured by Thayer School Computing Services. To install the client on your personal devices, follow the instructions below.

Installing Palo Alto GlobalProtect on a Personal Device

Full instructions for installing the GlobalProtect VPN client can be found on ITC's KB article here:

tl;dr:

1. Go to vpn.dartmouth.edu and pick the installer for your system.

1.5 Mac users, you will need to accept a kernel extension. If you are not automatically prompted, go to your System Preferences > Security & Privacy, and you should see an 'Allow' button. You may have to restart your computer for this to take.

F5 Edge Client For Mac

2. Portal is vpn.dartmouth.edu (if you're at DHMC use vpn-split.dartmouth.edu as your portal)